Outage
Incident Report for Emburse
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 02:29 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 05, 2020 - 20:58 UTC
Monitoring
This incident has been resolved.
Posted Feb 05, 2020 - 20:52 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2020 - 20:48 UTC
Update
We are continuing to investigate this issue.
Posted Feb 05, 2020 - 19:23 UTC
Investigating
We are currently investigating this issue.
Posted Feb 05, 2020 - 19:22 UTC
This incident affected: Emburse API and Emburse Web App.